Who's Online
20 visitors online now
2 guests, 18 bots, 0 members
Support my Sponsor

SharePoint Designer error : The server could not complete your request

Recently I found some forums issues where users are getting below error when try to connect to SharePoint using SharePoint Designer

Error : The server could not complete your request. For more specific information, click the Details button.

On a side note when you choose the details button for more specific information you are returned a blank form which is unhelpful.
In the Event Log on SharePoint server you will see below error:
————– Event Error ———————
Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/48626873

Exception: System.ServiceModel.ServiceActivationException: The service ‘/_vti_bin/client.svc’ cannot be activated due to an exception during compilation. The exception message is: Method not found: ‘System.String System.ServiceModel.Activation.Iis7Helper.ExtendedProtectionDotlessSpnNotEnabledThrowHelper(System.Object)’.. —> System.MissingMethodException: Method not found: ‘System.String System.ServiceModel.Activation.Iis7Helper.ExtendedProtectionDotlessSpnNotEnabledThrowHelper(System.Object)’.
at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.WebConfigurationManagerWrapper.BuildExtendedProtectionPolicy(ExtendedProtectionTokenChecking tokenChecking, ExtendedProtectionFlags flags, List1 spnList)
at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.WebConfigurationManagerWrapper.GetExtendedProtectionPolicy(ConfigurationElement element)
at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.ProcessWindowsAuthentication(String siteName, String virtualPath, HostedServiceTransportSettings& transportSettings)
at System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.CreateTransportSettings(String relativeVirtualPath)
at System.ServiceModel.Activation.MetabaseSettingsIis.GetTransportSettings(String virtualPath)
at System.ServiceModel.Activation.MetabaseSettingsIis.GetAuthenticationSchemes(String virtualPath)
at System.ServiceModel.Web.WebServiceHost.GetAuthenticationSchemes(Uri baseAddress)
at System.ServiceModel.Web.WebServiceHost.AddAutomaticWebHttpBindingEndpoints(ServiceHost host, IDictionary
2 implementedContracts, String multipleContractsErrorMessage)
at System.ServiceModel.Web.WebServiceHost.OnOpening()
at Microsoft.SharePoint.Client.Services.MultipleBaseAddressWebServiceHost.OnOpening()
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(String normalizedVirtualPath)
at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
— End of inner exception stack trace —
at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath)
at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)
Process Name: w3wp

————– Event Error ———————

Resolution:

Let us first try some Client side solution to resolve this issue. This will apply to SharePoint Online as well:
1. Make sure the o365 sites are added to the trusted sites
2. Make sure the WebClient services (Search: services.msc) is running
3. Try installing IE10 on computer
4. Install patch KB2846960 on computer
5. Log in to O365 make sure “keep me signed in is checked”
6. Check to see if open with windows explore is working by going to a document library and adding files using “add files with windows explore” if no error proceed if not no idea.
7. On the ribbon of the site you want to open click the edit in SPD icon.
Server Side Solution for On Premises SharePoint server:
1. Open IIS on SharePoint server > Expand server > Expand Sites > Select “SharePoint Web Services”
2. In right hand side pane select Authentication >
3. Now make sure you enable Anonymous Authentication, Asp.net Impersonation, Forms Authentication and Windows authentication.
4. Now click Start > Run > type IISRESET
If Above does not help open web.config
1. Open IIS on SharePoint server > Expand server > Expand Sites > Select 1st IIS site > Right click > Explore
2. Now Open the web.config file after taking backup of same
3. Find the line:
<system.serviceModel>

 

Now you need to add the following Line directly below the line:
<serviceHostingEnvironment aspNetCompatibilityEnabled=”true”/>

(A note that these are case sensitive. If you get a 500.19 error its because the tags are not using the correct CAML case. You can revert to old backup we took before editing this file).

4. Now click Start > Run > type IISRESET

Leave a Reply